Back to overview
Maintenance
App Update
Feb 21, 2026 at 1:00pm UTC
–
Feb 21, 2026 at 2:00pm UTC
Affected services
app.passpack.com
api.passpack.com
Resolved
Feb 21, 2026 at 3:01pm UTC
Maintenance complete
Affected services
Updated
Feb 21, 2026 at 1:09pm UTC
We are starting our application update
Affected services
Created
Feb 21, 2026 at 1:00pm UTC
We will be updating the application with enhanced user experience.
Affected services